home *** CD-ROM | disk | FTP | other *** search
/ Chip 2007 January, February, March & April / Chip-Cover-CD-2007-02.iso / Pakiet bezpieczenstwa / mini Pentoo LiveCD 2006.1 / mpentoo-2006.1.iso / livecd.squashfs / var / db / pkg / media-libs / fontconfig-2.2.3 / fontconfig-2.2.3.ebuild < prev    next >
Text File  |  2005-10-16  |  3KB  |  100 lines

  1. # Copyright 1999-2005 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. # $Header: /var/cvsroot/gentoo-x86/media-libs/fontconfig/fontconfig-2.2.3.ebuild,v 1.12 2005/05/03 15:31:22 usata Exp $
  4.  
  5. inherit eutils
  6.  
  7. DESCRIPTION="A library for configuring and customizing font access"
  8. HOMEPAGE="http://freedesktop.org/Software/fontconfig"
  9. #SRC_URI="http://pdx.freedesktop.org/software/fontconfig/releases/${P}.tar.gz"
  10. SRC_URI="http://freedesktop.org/fontconfig/release/${P}.tar.gz"
  11.  
  12. LICENSE="fontconfig"
  13. SLOT="1.0"
  14. KEYWORDS="x86 ppc sparc ~mips alpha arm hppa amd64 ia64 ppc64 s390 ppc-macos"
  15. IUSE=""
  16.  
  17. RDEPEND=">=media-libs/freetype-2.1.4
  18.     >=dev-libs/expat-1.95.3"
  19. DEPEND="${RDEPEND}
  20.     >=sys-apps/sed-4"
  21.  
  22. src_unpack() {
  23.  
  24.     unpack ${A}
  25.     cd ${S}
  26.  
  27.     local PPREFIX="${FILESDIR}/patch/${PN}"
  28.  
  29.     # Some patches from Redhat
  30.     epatch ${PPREFIX}-2.1-slighthint.patch
  31.     # Add our local fontpaths (duh dont forget!)
  32.     epatch ${PPREFIX}-2.2-local_fontdir-r1.patch
  33.     # Blacklist some fonts that break fontconfig
  34.     epatch ${PPREFIX}-2.2-blacklist.patch
  35.     # Remove the subpixel test from local.conf (#12757)
  36.     epatch ${PPREFIX}-2.2-remove_subpixel_test.patch
  37.  
  38.     # The date can be troublesome
  39.     sed -i "s:\`date\`::" configure
  40.  
  41.     epunt_cxx #74077
  42. }
  43.  
  44. src_compile() {
  45.  
  46.     [ "${ARCH}" == "alpha" -a "${CC}" == "ccc" ] && \
  47.         die "Dont compile fontconfig with ccc, it doesnt work very well"
  48.  
  49.     # disable docs only disables docs generation (!)
  50.     econf --disable-docs \
  51.         --with-docdir=/usr/share/doc/${PF} \
  52.         --x-includes=/usr/X11R6/include \
  53.         --x-libraries=/usr/X11R6/lib \
  54.         --with-default-fonts=/usr/X11R6/lib/X11/fonts/Type1 || die
  55.  
  56.     # this triggers sandbox, we do this ourselves
  57.     sed -i "s:fc-cache/fc-cache -f -v:sleep 0:" Makefile
  58.  
  59.     emake -j1 || die
  60.  
  61.     # remove Luxi TTF fonts from the list, the Type1 are much better
  62.     sed -i "s:<dir>/usr/X11R6/lib/X11/fonts/TTF</dir>::" fonts.conf
  63.  
  64. }
  65.  
  66. src_install() {
  67.  
  68.     make DESTDIR=${D} install || die
  69.  
  70.     insinto /etc/fonts
  71.     doins ${S}/fonts.conf
  72.     newins ${S}/fonts.conf fonts.conf.new
  73.  
  74.     cd ${S}
  75.  
  76.     newman fc-cache/fc-cache.man fc-cache.1
  77.     newman fc-list/fc-list.man fc-list.1
  78.     newman src/fontconfig.man fontconfig.3
  79.     dodoc AUTHORS ChangeLog NEWS README
  80. }
  81.  
  82. pkg_postinst() {
  83.  
  84.     # Changes should be made to /etc/fonts/local.conf, and as we had
  85.     # too much problems with broken fonts.conf, we force update it ...
  86.     # <azarah@gentoo.org> (11 Dec 2002)
  87.     ewarn "Please make fontconfig related changes to /etc/fonts/local.conf,"
  88.     ewarn "and NOT to /etc/fonts/fonts.conf, as it will be replaced!"
  89.     mv -f ${ROOT}/etc/fonts/fonts.conf.new ${ROOT}/etc/fonts/fonts.conf
  90.     rm -f ${ROOT}/etc/fonts/._cfg????_fonts.conf
  91.  
  92.     if [ "${ROOT}" = "/" ]
  93.     then
  94.         echo
  95.         einfo "Creating font cache..."
  96.         HOME="/root" /usr/bin/fc-cache
  97.     fi
  98.  
  99. }
  100.